Thursday, September 6, 2018

IBM AIX Interview Questions

What is IBM AIX ?
AIX(Advanced Interactive eXecutive) is a series of proprietary Unix operating systems developed and sold by IBM for several of its computer platforms. Originally released for the IBM 6150 RISC workstation, AIX now supports or has supported a wide variety of hardware platforms, including the IBM RS/6000 series and later IBM POWER and PowerPC-based systems, IBM System i, System/370 mainframes, PS/2 personal computers, and the Apple Network Server. AIX is based on UNIX System V with 4.3BSD-compatible extensions. It is one of four commercial operating systems that are presently certified to The Open Group’s UNIX 03 standard (The others are Mac OS X, Solaris and HP-UX.)
What is System Management Interface Tool (SMIT) ?
SMIT is the System Management Interface Tool for AIX. It allows a user to navigate a menu hierarchy of commands, rather than using the command line. Invocation is typically achieved with the command smit. Experienced system administrators make use of the F6 function key which generates the command line that SMIT will invoke to complete the proposed task. SMIT also generates a log of commands that are performed in the smit.script file. The smit.script file automatically records the commands with the command flags and parameters used. The smit.script file can be used as an executable shell script to rerun system configuration tasks. SMIT also creates the smit.log file, which contains additional detailed information that can be used by programmers in extending the SMIT system.
What are the unique features of AIX ?
The following are some unique system management features of AIX.
  • Logical Volume Manager :- The Logical Volume Manager (LVM) maintains the hierarchy of logical structures that manage disk storage.
  • System Resource Controller:– The System Resource Controller (SRC) provides a set of commands and subroutines for creating and controlling subsystems and is designed to minimize the need for human intervention in system processing.
  • Object Data Manager :- The Object Data Manager (ODM) is a data manager intended for the storage of system data.
  • Software Vital Product Data:- Certain information about software products and their installable options is maintained in the Software Vital Product Data (SWVPD) database.
Workload management :- Workload Manager (WLM) is designed to provide the system administrator with increased control over how the scheduler virtual memory manager (VMM) and the disk I/O subsystem allocate resources to processes. You can use WLM to prevent different classes of jobs from interfering with each other and to allocate resources based on the requirements of different groups of users.
Operating system updates:- The operating system package is divided into filesets, where each fileset contains a group of logically related customer deliverable files. Each fileset can be individually installed and updated.
What is VGDA?
Volume Group Descriptor Area. It contains the information about volume group to which the physical volume belongs to. It also contains the information about physical partitions, logical partitions and logical volumes.
How do I know if my volume group is normal, big, or scalable?
Run the lsvg command on the volume group and look at the value for MAX PVs. The value is 32 for normal, 128 for big and 1,024 for scalable volume group.
What does Logical Volume Manager(LVM) mean?
The set of operating system commands, library subroutines and other tools that allow you to establish and control logical volume storage is called the Logical Volume Manager (LVM).
How do I create a volume group?
Use the following command, where s partition_size sets the number of megabytes (MB) in each physical partition where the partition_size is expressed in units of MB from one through 1,024. (It’s one through 131,072 for AIX 5.3.)
mkvg -y name_of_volume_group -s partition_size list_of_hard_disks
The partition_size variable must be equal to a power of two (for example: one, two, four or eight). The default value for standard and big volume groups is the lowest value to remain within the limitation of 1,016 physical partitions per physical volume. The default value for scalable volume groups is the lowest value to accommodate 2,040 physical partitions per physical volume.
How can I change the characteristics of a volume group?
You use the chvg command to change the characteristics of a volume group.
What is the login process to the AIX system?
AIX is a multi-user system
When the user login he needs to provide the user name and password for authentication purposes.
After the successful login, AIX starts the SHELL program
How do I create a logical volume?
#mklv -y name_of_logical_volume name_of_volume_group number_of_partition
How do I increase the size of a logical volume?
To increase the size of the logical volume represented by the lv05 directory by three logical partitions, for example, type extendlv lv05 3.
How do I display all logical volumes that are part of a volume group (e,g, rootvg)?
You can display all logical volumes that are part of rootvg by typing the following command: #lsvg -l rootvg/
How do I list information about  logical volumes?
Run the following command to display information about the logical volume #lv1: lslv lv1.
How can I clone the rootvg?
You can run the alt_disk_copy command to copy the current rootvg to an alternate disk. The following example shows how to clone the rootvg to hdisk1: alt_disk_copy -d hdisk1.]
How do I replace a disk?
extendvg VolumeGroupName hdisk_new
migratepv hdisk_bad hdisk_new
reducevg -d VolumeGroupName hdisk_bad
How do I mirror a logical volume? 
mklvcopy LogicalVolumeName Numberofcopies
syncvg VolumeGroupName
How can I display or set values for network parameters?
The no command sets or displays current or next boot values for network tuning parameters
How do I get the IP address of my machine?
Type one of the following: ifconfig -a or host Fully_Qualified_Host_Name. For example, host cyclop.austin.ibm.com.
How do I identify the network interfaces on my server?
Either of the following two commands will display the network interfaces: lsdev -Cc if or ifconfig -a. To get information about one specific network interface, for eaxample tr0, run the command ifconfig tr0.
How do I activate a network interface?
To activate the network interface tr0, run the command ifconfig tr0 up.
How do I display routing table, interface and protocol information?
To display routing table information for an Internet interface, type netstat -r -f inet. To display interface information for an Internet interface, type netstat -i -f inet. To display statistics for each protocol, type netstat -s -f inet.
How will you create a file if a disk is given to you?
#mkvg –y datavg –s 128 hdisk1 (pv name)
#mklv -y datalv –t jfs2 datavg 1
#crfs –v jfs2 –d datalv –g datavg –a size=10M –m /fs1
Difference between JFS & JFS2?
JFS:
JFS is normal filesystem. We cannot create large files in JFS.
Files can be access dynamically.
Max file system size=1TB
Max file size=64GB
Inode size=128b
JFS2:-
Can create a large size filesystems.
Files can be access accordingly as required. (not randomly or sequentially)
Max files system size=4PB
Max file size=4PB
Inode size=512
How will you find the inode number?
# ls –li
# istat /etc/passwd
How will you find LTG size?
#lsvg vgname
#lquerypv –M hdiskname
How will you change LTG size?
#rmdev -l hdiskx
#chdev -l hdiskx -a max_transfer=0*80000
#mkdev -l hdiskx
How will you find whether a quorum is up or not?
# lsvg vg name
Get through the interview bar with our selected interview questions for IBM AIX Training enthusiasts
How to copy a LV from one VG to another?
# cplv -v <new vg name> <sourcelvname>
Mirroring concept?
Check disk size belong to vg , take two same size disk to mirror
# bootinfo –s hdisk2
#lsvg –p rootvg
Add one more disk of same size of already have disk having rootvg.
# extendvg rootvg hdisk2
# lsvg –p rootvg
Now mirror vg with background sync LV. It sync LVs in background with new LVs
# mirrorvg –s rootvg
Create a boot image
# bosboot –ad /dev/hdisk2
#bosboot –ad /dev/hdisk1
Add a blv
record of newly added disk, first check and then add.
# bootlist –m normal -o
#bootlist –m normal hdisk2 hdisk1
How will you unmirror a VG if a PV gets failed?
First check the blv record using,
# bootlist –m normal –o
Remove the old blv record, using
# chpv –c hdisk2
# bootlist –m normal hdisk1
# bootlist –m normal hdisk2
Now unmirrorvg
# unmirrorvg rootvg hdisk2
# reducevg rootvg hdisk2
#lsvg –p rootvg
# lspv
# bootlist –m normal –o
How will you change a PP size?
PP size can be changed using a T-factor. If not then add a partitions in VG by adding one disk.
# chvg –t3 rootvg
T – Factor?
T – factor means that it will change the pp size to increase the efficiency of vg
#chvg –t16 datavg
Cal-if suppose that datavg pp size is 1016 we can take t factor is 16 then it comes to 2048 and pv contains in vg is 2.
What is the default PP Size in AIX?
128MB
How will you rename a VG?
Unmount all filesystems in VG.
# umount /test (mount point name)
#varyoffvg datavg
#exportvg datavg0
Importvg with new name
# importvg –y newvg hdisk4
 What is major number?
A major number refers to a type of device. A device number is a major number, and a minor number specifies a particular device of that type or sometimes the operation mode of that device type.
 What will you do if a disk gets failed?
diag command
How to enable & disable quorum?
# chvg –vy pv_name
# chvg –vn pv_name
#chvg –Qn vgname
#chvg –Qs vgname
What are the types of error?
-H/W error
-S/W error
-Operator error
-Unknown error.
What are the error levels severity?
-permanent
-Temporary
-Informational
-Unknown.
What is the command to see the error log?
# errpt –a
# errpt –d H [H/W]
# errpt –d S [S/W]
What is the command to clear the errorlog?
# errclear
What is the command to increase the size of error log when it is ful?
#usr/lib/errdemon –s ____ [ size ]
What is the command to start , stop, restart and list a demon?
# startsrc –g [ Demon name ]
# stopsrc [Demon name ]
# refrest [Demon name ]
# lssrc –al
When does error demon start in boot process?
rc.boot phase 3
Which file that error daemon stay?
/usr/lib/errdemon
Two states of device availability and explain them?
Available state and defined state. When device is in defined state it means it cannot use. Not in ready state. Run cfgmgr try to make available known in the system that device. Available state means that device is ready to use
# lsdev –Cc disk
It displays which disks are available
How will you check whether a device is installed or not?
# lsdev –Cc disk
How to change a 64 bit kernel to 32 bit kernel?
-Modify the /usr/lib/boot/unix directory and the /unix directory to be   a symbolic link to the binary for the desired kernel.
-Run the bosboot command to write a new system boot image.
-Reboot the system.
The path name of the 64-bit kernel is /usr/lib/boot/unix_64, and the
path name of the multiprocessor versions of the 32-bit kernel is
/usr/lib/boot/unix_mp.
# ln -sf /usr/lib/boot/unix_mp /unix
# ln -sf /usr/lib/boot/unix_mp /usr/lib/boot/unix
# lslv -m hd5
# bosboot -ad /dev/ipldevice
# shutdown -Fr
# bootinfo -K (should now be 32)

How to change a 32 bit kernel to 64 bit kernel?
To truly change the kernel to 64-bit from 32-bit, the system must be at the AIX® 5.1 or AIX 5.2levels.
# bootinfo –y
It shows a kernel is either 32-bit or 64-bit.
To truly change the kernel to 64-bit from 32-bit, the system must be at the AIX® 5.1 or AIX 5.2levels.
# bootinfo –y
It shows a kernel is either 32-bit or 64-bit.
To change to a 64-bit kernel, enter the following commands:
# ln -sf /usr/lib/boot/unix_64 /unix
# ln -sf /usr/lib/boot/unix_64 /usr/lib/boot/unix
# lslv -m hd5
# bosboot -ad /dev/ipldevice
# shutdown -Fr
How many VGs can be created in a LVM?
255 any no. of vg can create.
Types of VG & explain about them?
Normal vg -32 pv, 256 lv
# mkvg –y normvg –s 128 hdisk4
Big vg :- 128pv,512lv
# mkvg -B –y bigvg –s 128 hdisk9
Scalable vg: -1024pv, 4096 lv
# mkvg –S –y scalvg –s  512 hdisk1
How to convert a normal VG to big & scalable VG and also Big to Scalable VG?
#chvg –B vgname      /big vg
# chvg –S/-G vgname  /scale vg
What is VGDA, VGSA?
VGDA: Volume Group Descriptor Area. It contains the information about volume group to which the physical volume belongs to. It also contains the information about physical partitions, logical partitions and logical volumes.
VGSA: Volume Group Status Area it contains the information about physical partition from all physical volumes of the same volume group. It contains the status of VG
Default dump device?
hd6
Default secondary dump device?
/dev/sysdumpdevnull
How find a system dump?
#sysdumpdev -L
Where the file does the paging space stay?
/etc/swapspaces
How will check whether a fix is installed or not?
# instfix –ik  ptfname
What are the two states of installation?
Applied and commit state
In applied state if want to do any changes on installed software then we can do
But in commit the changes are not allowed to do. Once did installation.
A committed fileset update cannot be rejected.
Output from the installp -s command, which is used to get a list of applied software fileset     updates and updates that are available to be either committed or rejected.
How will you reject a committed fileset?
# installp –r –g fileset name
How will you check whether service pack is installed or not?
# oslevel –s
What is the latest OS level?
#oslevel -rq
How will you check whether software is installed or not?
# lslpp -L |grep -i   (software_name)
How do you find history of a file set?
#lslpp –h
How to remove a failed package installation?
#installp -C
How do remove the entries of the device in the odm?
#rmdev -dl
What are the types of ODM Database ?
Pre-defined database PdDv, PdAt
Customised database CuDv, CuAt
ODM Commands.
odmcreate: To customize Odm
To remove ODM: odmdrop
odmdelete: To remove object from ODM
To see info in ODM  odmget
To change the fields in object class  odmchange
To add object to ODM  odmadd
Types of Installation?
New and complete overwrite
Migration
Preservation
Where does log files resides?
AIX logs messages as specified in /etc/syslog.conf file.
How to unlock user account?
chuser –a account=true username
How to lock a user’s account?
#chuser account_lock=true username
How do u take backup of file systems?
#backup -f /dev/rmt0
How will u restore a file from already take backup using backup?
#restore -xvqf /dev/rmt0
How will u append a file to a previous archive take by Tar?
#tar -rvf /dev/rmt0
What command to take backup other vg’s?
# savevg –if /dev/rmt0 /vgname
What command to restore backup of non – rootvg?
# restvg  –x –d –f /dev/rmt0

No comments:

Post a Comment